Knowledgebase: EC Online
EC Online - Online report is showing up blank
Posted by Becky Brickell, Last modified by Becky Brickell on 20 October 2017 07:56 AM

**This issue only affects self-hosted clients.**

ISSUE: When I try to run a report in EnergyCAP Online, the report never appears or shows up blank.


RESOLUTION: A recent update to the .NET version has caused the reports to "break". Follow the steps below to fix the EnergyCAP Online reports.
Please note you will need access to the IIS server in order to complete this process.

  1. Log into EnergyCAP Online.
  2. Open Developer Tools (found in your web browser's settings). 
    1. You will want to look at the Network tab/menu.
  3. Navigate to Reports in EnergyCAP Online. 
  4. Run a report.
    1. The type of report and filters are not relevant. 
  5. You should see a 404 error that appears in the Developer Tools. Within that error message will be a file path that is used to pull a report. Make note of this path, you will need it in the next step.
  6. On the IIS Server, follow the path from step 5 to the aspnet_client folder.
  7. Copy the newest existing version folder and paste into a new folder.
    1. Note: You do not want to overwrite any existing folder.
  8. Rename the folder to match the version that EnergyCAP Online is looking for based on the path from the 404 error (step 5).
(0 vote(s))
Helpful
Not helpful

Comments (1)
Doug Sims
19 October 2017 01:18 PM
This worked for us. Just a quick note. You can copy and paste the folder inside that same directory and it will name it with "-Copy" at the end. Then just rename it to the version it is looking for. In my case, it was wanting 4_7_2053 as the folder name.
Post a new comment
 
 
Full Name:
Email:
Comments: